Failed to add an item to cart


#1

I think I’ve found out why the sales have dipped to nothing. When accessing Amazon on my smartphone, I can’t add a lot of items to my shopping cart. When I check out the buying options and click the Add to Cart button, I am getting the following error message “Failed to add an item to cart.”

I am getting this error for Amazon and 3rd party sellers. Is this happening for anyone else? I’ve found a few items that I can add to cart but there are many that spit out this error. Seems to be working on desktop version of the website but not the iOS app.

Not sure about other platforms.


#2

You cannot add your own items to your cart.
Another person would have to try this.


#3

I have been experiencing the same problem you described since yesterday morning. Maybe their system is updating?


#4

I should add I am attempting to add “used” items from other sellers and Amazon. The only items that don’t return the error are “new” items.


#5

It is not working on the IOS app or desktop version on my phone for me. I haven’t tried another device yet.


#6

Same here. Can’t add many items to cart and I think this is why sales have dropped to nothing. Once again, we’re paying $40 a month to sell on this platform and we’re hit by constant technical issues every weekend when we would normally be flooded with orders.

Doesn’t Amazon understand how much this hurts them too?


#7

Why would I try to add my own items to my cart? I am talking about other people’s items. Duh.


#9

I’m looking to see if there’s a way we can open a ticket with Amazon. Can’t find any where were they mentioned they realize the problem exists and are working on it. Hopefully they are monitoring our conversation and looking into it. I’m very surprised how long it’s going on.


#10

My husband just tried doing the same thing on his iPad and he’s not a seller like I am. It worked fine! Not sure if it’s the device or the fact that I’m a seller. Still looking into it…


#11

OK it appears to be the iPhone for us. My husband )who does not have a seller account) tried it on his iPhone and had the same problem I did where is his iPad worked fine. I’m going to try to logon my seller account on his iPad and if it works then it’s definitely something that has to do with our iPhones.


#12

Cool_Change there is a known glitch ,with shopping on your iPhone, and many other smart phones… It’s known Amazon — just doesn’t do anything about it … Good software developers when they write applications test them on a plethora of different operating systems, phones, devices… Etc

You can complain, but I suspect they’re not going to do anything??


#13

It is also on android phones, not just iPhones. Any fix for this discovered? Thanks.


#14

Shame to hear. I think this is mainly why our sales are so slow and not the riots. Wish they would do something about it since it is hurt everything including Amazon and its customers.


#15

Can you buy those products now?
Has the problem been solved?


#16

I’ve realized the glitch is associated with the buy box. Initially I had no variations in the buy box and all said currently unavailable. Now two are in the buy box and says in stock. One is not and still shows currently unavailable. This is on both Android and iPhone app. I hope they fix the glitch soon. They are not responding to my ticket

b


#17

Has anyone gotten a resolution on this yet? This is happening to one of my products as well :worried:


#18

This is exactly the problem. Log in with another account (not your seller account) - and it will work.