Seller Central
Seller Forums

Amazon Seller Forums » Amazon Marketplace Web Service (MWS) » Marketplace Web Service (Amazon MWS) Questions

Thread: SSL Certificate problem
Thread Archived This thread has been archived - replies are not allowed.


This question is not answered.


Permlink Replies: 4 - Pages: 1 - Last Post: 16 Feb, 2015 4:42 PM by: David C.
valleypoint

Posts: 7
Registered: 23 Jul, 14 4:44 AM
Posted on: 22 Jan, 2015 4:16 AM  
Click to report abuse...
I am new to MWS i got the coding from the MWS developer service. the response i got is "SSL certificate problem: unable to get local issuer certificate". How to resolve this issue can anyone help me on this
Is this a helpful question? Yes 0   No
4 Replies
Sort replies by:
EMCP

Posts: 12
Registered: 16 Jan, 15 10:05 PM
Posted on: 23 Jan, 2015 10:29 AM   in response to: valleypoint in response to: valleypoint  
Click to report abuse...
Are you coding your own client? Did you try the provided clients? They handle everything for me.. in PHP at least.
Was this reply helpful? Yes 0   No 0
valleypoint

Posts: 7
Registered: 23 Jul, 14 4:44 AM
Posted on: 23 Jan, 2015 9:23 PM   in response to: EMCP in response to: EMCP  
Click to report abuse...
i got the sample code from the amazon MWS library only. do u have any sample code??
Was this reply helpful? Yes 0   No 0
Oneida Books

Posts: 22,850
Registered: 04 Mar, 12 10:55 PM
Posted on: 24 Jan, 2015 1:39 PM   in response to: valleypoint in response to: valleypoint  
Click to report abuse...
I believe this has been address before if you search the forum ... and recently.
Was this reply helpful? Yes 0   No 0
David C.

Posts: 9
Registered: 04 Mar, 12 4:38 PM
Posted on: 16 Feb, 2015 4:42 PM   in response to: valleypoint in response to: valleypoint  
Click to report abuse...
I was stuck on this issue and took me a day to resolve it. Here is what I found:

This link addressed the problem and has a solution for sellers:
https://sellercentral.amazon.com/forums/thread.jspa?messageID=2470351&#2470351

Basically, you can either:
1) disable CURLOPT_SSL_VERIFYPEER
(which I am not sure is the best way to go due to security risk)

or

2) download the latest cacert.pem (http://curl.haxx.se/ca/cacert.pem) bundle from the below and add to your php.ini configuration to tell the client to use this new bundle
curl.cainfo="c:\your-path-to\cacert.pem:

But I was still getting the error with the new bundle. So I found downloaded AWS SDK for PHP and used the cacert.pem bundled from there.

That did the trick for me. Hope this might help someone out there.
Was this reply helpful? Yes 0   No 0