Seller Central
Seller Forums

Amazon Seller Forums » Login With Amazon » Login With Amazon Developers

Thread: LWA API response time issue
This question is not answered.


Permlink Replies: 0 - Pages: 1
Universal Devic...

Posts: 2
Registered: 15 Aug, 15 6:43 PM
Posted on: 23 Oct, 2016 8:26 AM  
Click to report abuse...   Click to reply to this thread Reply
Hi,

We are using LWA in the context of an Amazon Echo smart home skill. Within the skill, for each requests, we make the following 2 calls to LWA:
https://api.amazon.com/auth/o2/tokeninfo
https://api.amazon.com/user/profile

Most of the time, the response time is excellent. However, sometimes, both can have a long delay to respond. Most of the time, if one is long to respond, the other one will also be long, but there are exceptions. Sometimes, just one of the 2.

Here's some numbers I compiled recently.

I analysed the response time over the previous 24 hours.
658 out of 124242 requests (/user/profile or /auth/o2/tokeninfo) had a response time of > 5 seconds. That's about 0.5% of the total requests.

Sometimes there's a peak in the number of delayed response. As an example, between 5-6am (Oct 20th),
154 out of 4515 request were above 5 seconds, which is about 3%.

The problem appears on both endpoints, just about equally.
Sometime a request may take as long as 2 minutes before we get a response from the API, and most of the time, we do get a response (Not a socket disconnection or other error).

To me, it looks like our calls to LWA are throttled, but I'm not sure.

Anyone experiencing this?
Is this a helpful question? Yes 0   No
0 Replies
Sort replies by: