The error code 5665


#1

Hello,
I keep getting an error message while registering a product.
Message is " You must register your Brand with Amazon before listing ASINs with this Brand name. Please ensure you are complying with our Brand Name Policy https://sellercentral.amazon.com/gp/help/G2N3GKE5SGSHWYRZ. If this Brand is a registered trademarked, please enroll it at https://brandservices.amazon.com/eligibility. If it is not a registered trademarked, and you believe you are complying with our Brand Name Policy contact Seller Support and mention the error code 5665."
Do I have to register my brand? I would like to register a product without brand registration like any other product.
I would really appreciate it if you could tell me how.
Thank you.


How to Fix
Error 5665
Listing without a Trademarked Name/Logo
Does listing a new product require brand registry if I'm using FBA?
New Listing
5665
Error 5665
#2

This is also something I am stuck on at the moment. If anyone has anything to share on this, it would be greatly appreciated.


#3

I am having the same issue as well, it is showing error code 5665 while creating a listing. Is there a suggestion on how to resolve this issue ?


#4

Same problem here. I’ve created a case and contacted seller support through phone as well. They are trying to solve this issue, been 3 days now without any update though. I think it’s a relatively new error code cause there’s no info at help tab regarding error code 5665. Most error codes at least have a guide as to how to troubleshoot the issue. That’s not the caae for error code 5665. Will keep you updated.


#5

Im having the same problem, hopefully this gets resolved quickly


#6

I am having same problem. Even if i put some every uncomment name as brand it gives me same error. Hope amazon give us some quick solution.

Though i am not getting error with certain words and name. But sadly I am getting error with my brand name.


#7

Does anyone had any success with this issue? I have submitted the case with seller support but they have been able to solve the issue yet.


#8

Has anyone found the solution?


#9

This has been happening since early last week. There are a few other threads on this “ASIN already matching.” No answers though. My research so far tells me that Amazon is now “trying” to match brands to the GS1 UPC database. This is where the problem is coming in, because either the GS1 database Amazon is using is old and not updated, or the there is some issue with how the brands are using UPC’s relative to GS1. I haven’t figured it out yet, but it’s a huge problem. You can go to the GS1 website and put in the UPC you are trying to list, and it will bring up the Brand/Company that has registers that UPC/ GTIN. Chances are HIGH that it is not the brand you are trying to list, even though the UPC is on your product, receipt, and using the prefix GTIN of that Brand (5-7 digits). I’m at a total LOSS!!! @SEAmod we could use some help! Also someone should combine these threads.
If anyone figures this out, please update!


#10

From where did you guys purchased your UPC code? I think the issue is that we have to purchase UPC code from GS1 website only as it is unique for your brand. If the UPC code is from any other reseller website than it would not work.


#11

I didn’t purchase the UPC codes, they are the brand UPC codes on the brand product and receipt I’m trying to list. The problem is, Amazon says this brand is now registering their UPC’s with GS1 so unless it matches, I get the error. However, the GS1 database is showing these UPC’s registered to another random company with no web presence and from what I can tell, one employee. The Brand I’m trying to list is a billion dollar company. I’m stumped.


#12

I am also getting this error trying to add a product and cannot for the life of me figure out why! Has anyone got a response from amazon support yet and can provide further insight?


#13

Just got off a 45 minute call with Seller Support. They can’t fix it. They have to put in a ticket to the Brand Division. He couldn’t even tell what the problem was, let alone what code 5665 was. Now we have to wait for Brand Division to respond.

Anyone know of a way to contact brand division?


#14

No. So frustrating! I took the day off trying to figure it out, shipping items in that I can. No more sourcing for me until this gets resolved​:slightly_frowning_face:. My problem is that the UPC’s from the brand I’m listing (big, billion dollar brand) match to another company in GS1. Amazon told me to contact GS1 to tell them their database is wrong​:rofl::rofl::rofl:. And no, I didn’t buy these UPC’s, they are legit on the products and sales record I’m listing.


#15

We own the company that the UPC’s are registered to, and it’s the same company name as on the Seller Central Account, which they required full documentation to set up, but we still can’t get it to work!


#16

Did you check GS1 to see who the UPC’s are registered to in GS1?


#17

Guys for the benefit of others facing issue. I just started with my first listing and I run into to 5665 error, I tried getting support but as this is a new issue, support team couldn’t help. They seem to be not aware or something.

But for me error is gone on its own. I kept checking and kept trying to edit my incomplete draft listing and after 2 days I saw that error was gone (seem like error is to do with some databases update they might be doing, not sure) I suggest try editing draft or delete incomplete listing and try creating again.

Hope it works for you guys too. Let me know if any help with anything.


#18

@Blissful_Dining you are a new seller with a new brand? did you buy your barcodes directly from GS1? and if so did you register your brand name or comapny name as the ‘company prefix’?

Interesting that the error disappeared for you. Still appearing for me.

Is there a way we can check online what GS1 has registered against the barcode we have?


#19

What I can’t wrap my head around is that this huge billion dollar brand has registered their main UPC prefix with GS1, yet random complete UPCs that contain this same prefix seem to be registered to some unknown small company. How can that happen? What am I not understanding about this GS1 registration process?


#20

I second Dance_Mom’s inquiry. Have you checked to see if GS1 actually shows your company is the registered owner of the UPC’s? I would be very interested in hearing the results of your search because it would give a glimpse as to where this problem originates?