Signature doesn't match error even when we use URL from mws scratchpad


#1

Hello everyone,

I already built a tool in google apps script which works well with APIs associated with MWS. I am now working to build similar on NodeJs. But now I am trying to post URL but getting this error

<Message>
The request signature we calculated does not match the signature you provided. Check your AWS Secret Access Key and signing method. Consult the service documentation for details.
</Message>

I checked signature and is generated properly, I took url from mws scratchpad and tried it on browser. Even it throws the same error while it gave proper valid response at scratchpad.

I also tried generating URL from my previous running project which is giving proper responses, pasted them in browser’s address bar, and here also it is giving the same error.

What could be the reasons for this?

Kind Regards,
Aitha Rajesh.


#2

You can’t use the url from MWS scratchpad on a browser as it will try a “GET” request instead of a “POST” you have to use something like Postman to emulate the “POST”. If you already have an app that can do this signature all you need to do is compare the two signatures.


#3

it works now!!
Previously when I checked the signature was same with the old one. The difference was that in new system I was doing post in string to sign and the doing get request.
Once I change that it is working perfectly.

Thanks for your response.