Access to MWS API is denied


#1

Hello,

I am trying to develop MWS application so I checked the access in MWS scratchpad.
But I got the message that ‘Access to Orders.ListOrderItems is denied’.
I typed SellerId, AWSACccessKeyId, SecretKey but not MWSAuthToken because it is my own store.
I also checked my developer authorization date, it is 09/26/2018.
I have no idea what I should do or if there is mistake


Response time from MWS support
MWS Access Denied, Error 401
No response from support about AWS Credentials for over 60 days
Valid MWS credentials provided, got AccessDenied error in app and Scratchpad
#2

This part is correct …

So also good.

Worked fine for me …

You did put in an AmazonOrderId ?
Do you have any orders ?
image


#3

yes I did put amazon order id what i have


#4

Try making the GetServiceStatus call just to make sure that it is indeed the credentials since it doesn’t take any parameters at all asides from credentials.


#5

I got the ‘GREEN’


#6

You get GREEN even with the wrong credentials in there …


#7

I tried making ListMarketplaceParticipations call and I got message that ‘The AWS Access Key Id you provided does not exist in our records.’

I typed the access key id from the this page, so if I typed correctly,
should I have to contact with Amazon Seller support?

Thank you


#8

Just to be clear it was the credentials after you click on the View link under MWS credentials correct? And if that is the case it looks like something happened to your credentials and Amazon may need to intervene.


#9

Just to be clear … You are using your MWS Keys and NOW AWS Keys ?

Some get confused because it says “AWS…”


#10

Hey, how did you solve the problem? Can you please share?


#11

Me Too. I’ve got a request in with Seller Support (MWS Support). I give them most of the information, and then a day later, they respond and ask me to reply with most of the details I already provided. That’s the mark of a busy support person who wants to push 'til next week, as I responded back right away on Friday, but heard nothing all day and we’re into the weekend.

Anyway, I originally signed up for developer keys for my own store back in 2012, but I’m not getting around to making use of them. The idea what that I only had enough time to dabble, and I set up my store with a bunch of third party solutions and haven’t got around to dabbling with MWS.

I’ve verified my Merchant/Seller ID, I’m a professional seller, I’ve carefully cut and pasted my AWS Access Key ID and my Secret Key numerous times to be sure they were correct.

And making calls from the MWS Scratchpad all fail with “Access Denied” responses, with the exception of course of GetServiceStatus which doesn’t require credentials.

PS: I’ve come across dozens of threads about similar experiences that have a bunch of responses, but never any indication of if the person resolved it, what fix resolved it, or anything else useful. Please, if you ask a question and figure it out, do the community a favor and come back and tell us what fixed it for you. Or just delete your post if you never figured it out. So much wasted time this week reading threads that peter out into nothingness.


#12

Hey, how did you solve the problem? Can you please share?


#13

I believe Amazon Support had to step in. If you haven’t already done so open a ticket.


#14

@Autou: I have not managed to solve the problem yet.

@Buildcom: I opened a ticket with MWS support, supplying them with all the information that they should have needed to look into and report back on what the problem was (or fix the problem if it was on their end.) A day later received a boilerplate response asking me to provide various bits of information which I had already provided them. It’s now been 10 days since I asked for help. I have not heard back. I even pingged them again on that open case saying, “I really could use some attention on this. Please respond.” around the 5-day mark. Still no reply.

I think I’m going to just create a whole new case with all of the details and see if that gets a reply quicker. I will return if I get help and get it working.


#15

I have the same issue here. Please share the solution if the problem is solved.


#16

submit the case to Amazon, but they do not reply any more.


#17

Finally, a response from Support, here is what they had to say to me. I haven’t done anything with the link. Just showed up for work a while ago, have a bunch of things to get to before I can concentrate on this:


Hello,

Thank you for submitting your registration for MWS Access Keys.

We have a new Developer Registration and Assessment form that allows developers to submit information about their applications so we can assess compliance with our Amazon MWS data protection requirements, and help to make sure that we provide the right level of access that you require. Please complete this new Developer Registration and Assessment form. Completion of this form is the only way to obtain Amazon MWS Access Keys.

Note that in order to access the form, you need to log into your Amazon selling account as the primary account holder.

Please review the Amazon Data Protection Policy and Acceptable Use Policy to help you complete this process:
http://docs.developer.amazonservices.com/en_US/dev_guide/DG_DataProtectionPolicy.html
http://docs.developer.amazonservices.com/en_US/dev_guide/DG_AcceptableUsePolicy.html

For more information about the Developer Registration and Assessment form, please see our FAQ:
http://docs.developer.amazonservices.com/en_US/faq.html

Thank you for helping all of us continue to put data protection first.

Thank you for selling with Amazon,

Amazon.com Seller Support


If anybody finds success before I do, let us all know what steps you took, especially if they weren’t obvious and what additional things you had to do. Thank you so much. I hope my sharing helps.


UPDATE: After looking at all of the links, they are just pages where Policies are spelled out. And the FAQ link includes instructions that don’t address my issue. It tells me how to go into my account and request an access key and secret key… I already have those. I can’t do anything with them. I can’t delete and create new ones. And I don’t know where to find any new developer registration and assessment forms. I have to assume they pop up when first creating your MWS keys, but mine were created a while back.

-mark


Working with MWS scratchpad and I can't seem to access Reports
Access to Feeds.SubmitFeed is denied
#18

I am having the same issue. My DeveloperID is reporting as “invalid” when a seller puts it in their account. Also I get “access denied” when I use my own developer credentials against my own account.

I opened ticket 5785855061 with support, and the first reply said:
“Upon checking with my internal tools, I see that the MWS authorization for your account is deactivated which is why you receiving the error while trying to access API using your MWS keys”

I received no notice that this deactivation took place. There is no indication in my seller account that my developer id is not active. My developer ID worked previously, but I hadn’t used my developer ID for the last few months because of focus on other projects. I understood Amazon was cracking down on giving out new Developer IDs.

I am aware of one DeveloperID that was registered some years ago, has been in active daily use, and its still active, without having to go through the new developer registration process.

I am aware of two other Developer IDs (other than my own) who applied under the old procedure, but haven’t been actively used recently, and those Developer IDs also deactivated.

My current assumption is Amazon deactivated developer IDs that haven’t been used for a period of time, and is making all of those users reapply from scratch.

The first reply from tech support also said:
“Hence, to get the MWS ID and ACCESS key, you have to register again as a Developer. You can apply for Amazon MWS Developer API Access keys from your Seller Central account, from Settings > User Permissions, and clicking the “Visit Developer Credentials” button.” … “Once you apply, Amazon will thoroughly review your business information and intended use case before granting MWS access keys. This process may take up to 30 days.”

The problem is, once on the “Developer Central” page, THERE IS NO BUTTON OR LINK TO REAPPLY to be a developer. (The page only shows my existing, and deactivated, Developer ID.)

In my first reply to the ticket, I documented this fact including providing a screen clip of my “Developer Central” screen. In addition, I asked when and why my existing Developer ID has been deactivated.

In the second reply I got from tech support, my issue of not finding the link to re-apply, in addition to my questions about my previously active developer ID, WERE IGNORED. The only thing I got back in the second reply from tech support was a number of links to the instructions I was already provided in the first reply. (The exact same email as BrickOvenMaker received as noted above my post.)

I just submitted again the issue of no apply link showing up on my “Developer Central” page, and I attached the same screen clip as in my first reply.

It seems my ticket was routed to a different department, as I got the second reply from "dev-reg-vetting@amazon.com". So it seems the ticket has been routed to “developer registration vetting”, so I guess that is some progress. :slight_smile:

I will keep this thread updated.


#19

Amazon support provided this link to one of my friends. This is where you go if you already have a Developer ID that is not working and you need to apply again:

https://sellercentral.amazon.com/mws/register/warning

I suggest you not just read, but study, these links before applying:
http://docs.developer.amazonservices.com/en_US/dev_guide/DG_DataProtectionPolicy.html
http://docs.developer.amazonservices.com/en_US/dev_guide/DG_AcceptableUsePolicy.html


#20

Update from my previous post:

Amazon has now added “Status” to the screen where you see your MWS developer ID, after signing in to your seller account, at this URL: https://sellercentral.amazon.com/marketplacedeveloper/applications Mine says “Deactivated”, which explains why it doesn’t work anymore. My application to get it reactivated has been pending since Feb 21st, and I haven’t heard anything back yet.

Also FYI, I was repeatedly told by Amazon support to go to this link to re-register, but also this link has no button on the screen to reregister: https://sellercentral.amazon.com/mws/register/developer-info When pointing out to support there is no way to re-register from that page, and asking them to point out where on the page to click to re-register, they just ignore my comments and again reply with the exact same text and link that does not work. (The link that works is in my previous comment.)


Access to Feeds.SubmitFeed is denied